Nouveau composant 1-wire (ou plutôt clone - DS2413)

Message
Auteur
Avatar de l’utilisateur
Dim
Utilisateur
Messages : 251
Inscription : mar. janv. 18, 2011 5:39 pm
Localisation : 91-Essonne (proche Arpajon)
Contact :

Nouveau composant 1-wire (ou plutôt clone - DS2413)

#1 Message par Dim » sam. déc. 10, 2016 3:31 pm

Bonjour,

je viens d'acheter des DS24-13, via ALi-express.
Hélas à réception, ils ne sont pas marqués DS2413 mais 3A-2100H.
Logisdom ne les reconnait pas. Mais le HA7-Net les identifie, ils semblent donc OK d'un point de vue 1-Wire.
Famille 85H... recherche sur Internet, ils sont connus comme clones du DS2413...

Rémy, y aurait-il moyen d'ajouter ce code famille sur la gestion du DS2413 stp?

Merci,
Dim.

Avatar de l’utilisateur
Serge67
Beta-Testeur
Messages : 165
Inscription : mar. janv. 18, 2011 5:38 pm
Localisation : Alsace, 35Km de Strasbourg
Contact :

Re: Nouveau composant 1-wire (ou plutôt clone - DS2413)

#2 Message par Serge67 » sam. déc. 10, 2016 5:48 pm

Bonjour Dim,

Dommage que les composants ne fonctionnent pas :cry:. J'avais déjà envie de commander également des composants 1-wire sur alix-express, notamment des DS2423 qui ne sont plus fabriqués.
Vu ton expérience, je crois que je ne vais pas m'y risquer ;) .
J'espère que Rémy va pouvoir y remédier, mais les codes ne doivent pas être évident à trouver je pense.

Cordialement

Serge

Avatar de l’utilisateur
Dim
Utilisateur
Messages : 251
Inscription : mar. janv. 18, 2011 5:39 pm
Localisation : 91-Essonne (proche Arpajon)
Contact :

Re: Nouveau composant 1-wire (ou plutôt clone - DS2413)

#3 Message par Dim » sam. déc. 10, 2016 6:02 pm

Bonjour Serge,

D'après plusieurs discussions sur des forums que j'ai pu parcourir en cherchant à quoi j'avais affaire, il semble qu'il y ai vraiment compatibilité à à part le code famille, au moins entre ds2413 et son clone.
Pour les DS2423, je ne sais dire, par contre il m'en reste quelques uns de ma commande d'il y a quelques années, en format DIL-8, il en est question ailleurs sur le forum... si ça peut te dépanner...
Dim

Avatar de l’utilisateur
Remy
Administrateur du site/Developpeur
Messages : 352
Inscription : lun. janv. 17, 2011 6:10 pm
Localisation : 40km est de Lyon
Contact :

Re: Nouveau composant 1-wire (ou plutôt clone - DS2413)

#4 Message par Remy » dim. déc. 18, 2016 10:48 pm

Bonsoir,
Pas de soucis, je vais modifier le code de LogisDom pour qu'il prenne en charge ces composants.
ça ne devrait pas être très compliqué dans la mesure ou il semble 100% compatible avec les originaux.
Si ça ne marche pas du premier coup il faudra m'en envoyer un pour que je fasse des essais.
a plus,
Remy.
Version 1.612 dispo modifiée http://logisdom.fr/downloads/

Avatar de l’utilisateur
Dim
Utilisateur
Messages : 251
Inscription : mar. janv. 18, 2011 5:39 pm
Localisation : 91-Essonne (proche Arpajon)
Contact :

Re: Nouveau composant 1-wire (ou plutôt clone - DS2413)

#5 Message par Dim » lun. déc. 19, 2016 1:07 am

Bonsoir Rémy,

Toujours une réactivité formidable... ;)
Je viens de charger la version Windows, pour un test rapide :
pb sur le dézip (avec 7z) du dernier fichier
Erreur de donnée : LogisDom_1.612_Windows\Qt5WebKit.dll
.
J'ai repris celui de la version précédente, semble être le même.
Installation du Ha7Net, Search et le composant est trouvé, par contre ça bloque sur le

Code : Tout sélectionner

*ReadDualSwitchREC#{ED1003C0741DE85_A}
J'ai fait enregistrer le log du HA7Net, je te l'envoie par mail. (le "vrai" Logisdom tourne en parallèle, donc accès concurrents au HA7Net, mais il est supposé le supporter...)
Je t'envoie un composant ce lundi.

A+
Dim.

Répondre