Version 1.321

Que fait-il, a quoi sert-il?
Répondre
Message
Auteur
Avatar de l’utilisateur
Remy
Administrateur du site/Developpeur
Messages : 352
Inscription : lun. janv. 17, 2011 6:10 pm
Localisation : 40km est de Lyon
Contact :

Version 1.321

#1 Message par Remy » lun. mai 20, 2013 9:06 pm

Voici une nouvelle version avec quelques nouveautés.

J'ai mis en lumière une faille de stabilité qui pourrait améliorer la situation au niveau des plantages intempestifs.

Les nouveautés :
- gestion des DS2406 TO92, ceux avec une seule sortie.
- fonction YearBefore, MonthBefore pour faire du calcul de bilan annuel/mensuel du années fixes
- ajout du paramètre durée pour MeanRomID, MaxRomID, MinRomID, SumRomID, CountRomID, DataCount toujours pour faire du calcul de bilan sur année/mois précédents
- ajout de la fonction Dupliquer icônes avec formule quand ils sont associés à une capteur virtuels, utile pour dupliquer une paire icône/capteur virtuel quand on a plusieurs calculs similaires.
- correctif pour les tableaux et csv

Le téléchargement des nouvelles versions se fait toujours ici : http://logisdom.fr/downloads

moriss
Messages : 174
Inscription : ven. nov. 11, 2011 9:19 pm

Re: Version 1.321

#2 Message par moriss » mar. mai 21, 2013 8:06 am

Merci je test dans la journée

Avatar de l’utilisateur
Serge67
Beta-Testeur
Messages : 165
Inscription : mar. janv. 18, 2011 5:38 pm
Localisation : Alsace, 35Km de Strasbourg
Contact :

Re: Version 1.321

#3 Message par Serge67 » mar. mai 21, 2013 3:40 pm

Merci Rémy pour cette mise à jour :D
Je viens de l'installer, pour l'instant pas de soucis :D

Merci est bonne semaine à tous

Serge

Avatar de l’utilisateur
Dim
Utilisateur
Messages : 251
Inscription : mar. janv. 18, 2011 5:39 pm
Localisation : 91-Essonne (proche Arpajon)
Contact :

Re: Version 1.321

#4 Message par Dim » jeu. mai 23, 2013 10:25 pm

Salut,

Nouvelle version installée ce soir (Ubuntu 64).
Je n'avais pas vu... je n'ai plus les messages automatiques de mise à jour du forum depuis plusieurs semaines, je ne comprends pas pourquoi...

Dim.

Avatar de l’utilisateur
Serge67
Beta-Testeur
Messages : 165
Inscription : mar. janv. 18, 2011 5:38 pm
Localisation : Alsace, 35Km de Strasbourg
Contact :

Re: Version 1.321

#5 Message par Serge67 » mar. mai 28, 2013 4:56 pm

Salut Rémy,

J'ai un mauvaise nouvelle :( . J'avais mon premier plantage aujourd'hui avec cette nouvelle version :(

Je ne sais pas si cela peut t'aider, mais je te joins le message d'erreur affiché par Windows 7. La première fenêtre et affiché en double.
Plantage LogisDom.png
Plantage LogisDom suite.png
Bonne soirée

Serge

Avatar de l’utilisateur
Remy
Administrateur du site/Developpeur
Messages : 352
Inscription : lun. janv. 17, 2011 6:10 pm
Localisation : 40km est de Lyon
Contact :

Re: Version 1.321

#6 Message par Remy » jeu. mai 30, 2013 8:45 am

De mon cote, sous Ubuntu32 j'ai pas eu de plantage depuis cette version.
Je suis repasse sous XP pour voir.
J'aurais besoin d'autre retour d'experience avec cette version avant de commencer a fouiner.

Remy.

moriss
Messages : 174
Inscription : ven. nov. 11, 2011 9:19 pm

Re: Version 1.321

#7 Message par moriss » jeu. mai 30, 2013 10:27 am

salut remy,

perso j'ai toujours aussi des beug, vais voir pour obtenir le log comme serge
frequence beaucoup moins elevé, j'ai du avoir 3 plantage depuis la release

Avatar de l’utilisateur
Serge67
Beta-Testeur
Messages : 165
Inscription : mar. janv. 18, 2011 5:38 pm
Localisation : Alsace, 35Km de Strasbourg
Contact :

Re: Version 1.321

#8 Message par Serge67 » jeu. mai 30, 2013 8:15 pm

Bonsoir à tous,

Rémy, je remarque des choses assez bizarre lors du plantage.
- il y a souvent plusieurs fenêtres d'erreur (la plus pars du temps, 2) comme si plusieurs modules différents plantent à des
moments différents.
- Certaines fonctionnalités continue à tourner pendant plusieurs heures avant de planter.

Pour pouvoir t'aider à mettre de doigt dessus, existe t-il un Log général sur tout ce que fait LogisDom, qu'on pourrait activer?

Lors du prochain plantage, je vais essayer de trouver l'ordre de plantage des différents modules.

Bonne soiré

Serge

Avatar de l’utilisateur
Dim
Utilisateur
Messages : 251
Inscription : mar. janv. 18, 2011 5:39 pm
Localisation : 91-Essonne (proche Arpajon)
Contact :

Re: Version 1.321

#9 Message par Dim » sam. juin 01, 2013 11:30 am

Bonjour,

J'ai aussi eu des redémarrages avec la version Ubuntu 64.
Je viens de modifier mon watchdog afin qu'il journalise les redémarrages (date/heure/version).

Dim.

Avatar de l’utilisateur
Serge67
Beta-Testeur
Messages : 165
Inscription : mar. janv. 18, 2011 5:38 pm
Localisation : Alsace, 35Km de Strasbourg
Contact :

Re: Version 1.321

#10 Message par Serge67 » mer. juin 05, 2013 8:50 am

Bonjour,

Nouveau plantage entre hier et ce matin ;)

Comme promis j'ai récupéré un max d'infos (9h ce matin).

- L'heure affiché dans onglet "maison" c'est figée à 12h42 le 4-06
- L'heure affiché sur PNG "maison" c'est figée à 6h28 le 5-06 par contre les animations sur cette image ne semblait pas correspondre (production solaire en cours à 6h du matin :D , le soleil me chauffe même la nuit ;) )
- Log du ha7s, m-bus et 2éme ha7s tournait encore sans problème ce matin et les lectures semblaient ok.
(pour la com. Resol et Télé-info il ne me fait pas de Log!! Donc pas d'info sur l'horaire)
- Mise à jour des valeurs dans le tableau (enregistrement horaire) à fonctionné jusqu'à 6h00
- Toutes les valeurs .DAT se sont figées à 6h29 le 4-06

En conclusion, il semblerait que l'affichage direct dans LogisDom se fige en premier puis les tableaux et PNG. La lecture du réseau Ethernet fonctionne sans problème jusqu'à la fermeture de LogisDom.

Peut-être que cela pourra servir à notre GRAND MAITRE programmeur ;)

Bonne journée à tous

Serge

Avatar de l’utilisateur
Dim
Utilisateur
Messages : 251
Inscription : mar. janv. 18, 2011 5:39 pm
Localisation : 91-Essonne (proche Arpajon)
Contact :

Re: Version 1.321

#11 Message par Dim » lun. juin 10, 2013 8:18 am

Bonjour,

J'ai eu un plantage/redémarrage de Logisdom samedi soir, après environ 7jours et 6 heures de fonctionnement.
Cela dit ça coïncide à peu près avec un orage. Pour autant, Ubuntu lui n'a pas redémarré...
Dim.

Avatar de l’utilisateur
Dim
Utilisateur
Messages : 251
Inscription : mar. janv. 18, 2011 5:39 pm
Localisation : 91-Essonne (proche Arpajon)
Contact :

Re: Version 1.321

#12 Message par Dim » lun. juin 17, 2013 9:08 am

Bonjour,

Nouveau redémarrage inopiné de Logisdom le vendredi 14 17:41...
Rémy, Serge67, des idées sur un log + précis à activer?

Dim.

Avatar de l’utilisateur
Remy
Administrateur du site/Developpeur
Messages : 352
Inscription : lun. janv. 17, 2011 6:10 pm
Localisation : 40km est de Lyon
Contact :

Re: Version 1.321

#13 Message par Remy » lun. juin 17, 2013 6:54 pm

Bonsoir tout le monde.
Merci pour vos retours.
J'ai une piste assez claire pour les plantages, mais pas de solution dans l’immédiat ... j'y travaille ardemment ...
suite au prochain épisode.


Rémy.

Avatar de l’utilisateur
Serge67
Beta-Testeur
Messages : 165
Inscription : mar. janv. 18, 2011 5:38 pm
Localisation : Alsace, 35Km de Strasbourg
Contact :

Re: Version 1.321

#14 Message par Serge67 » mer. juin 19, 2013 9:01 pm

Bonsoir à tous,

Merci Rémy pour cette bonne nouvelle :)

Petite info supplémentaire: j'ai discuté avec Léo, il tourne sous Windows 7 avec la version 1.217a sans aucun plantage.
Donc, peut-être qu'il faut se pencher sur les parties rajoutées entre temps ;)

De mon coté j'ai eu 2 plantages depuis le dernier post, à environ 5 à 6 jours d'intervalle. Par contre la réaction lors du plantage et à chaque fois différent. Je n'avais pas activé les Log, mais j'avais l'impression que tout c'est figé en même temps.

Rémy, n'y travail pas trop ardemment, profite des beaux jours après ce printemps pluvieux!!!


Bonne soirée

Serge

Répondre